Canadian scholars
Engaging ideas, transforming minds
Engaging ideas, transforming minds

On April 7th, 2014, information regarding the "Heartbleed Bug" was announced to the general public. This is a security vulnerability that has been present in a version of the OpenSSL software widely used throughout the internet since 2011. While we do not have any reason to believe that we were affected, we have taken steps to protect our customers. We strongly encourage you to change your password on cspi.org and on other websites that you visit. For more information, visit http://heartbleed.com/.

To change your password on cspi.org, log in and select "Account" at the top left of the screen. Enter and re-enter your new password and click "Update." Passwords must be at least 8 characters long.

If you have any questions regarding your account on cspi.org, please contact us at marketing@cspi.org.